Welcome to Australia's only Vintage Radio and Television discussion forums. You are not logged in. Please log in below, apply for an account or retrieve your password.
Australian Vintage Radio Forums
  Home  ·  About Us  ·  Discussion Forums  ·  Glossary  ·  Outside Links  ·  Policies  ·  Services Directory  ·  Safety Warnings  ·  Tutorials

Tech Talk

Forum home - Go back to Tech talk

 Kriesler 11-77/78
« Back · 1 · 2 · 3 · 4 · 5 · 6 · Next »
 Return to top of page · Post #: 1 · Written at 7:10:45 PM on 9 April 2020.
Padge's Gravatar
 Location: Umina Beach, NSW
 Member since 9 April 2020
 Member #: 2410
 Postcount: 33

Hey guys and gals I'm new on here so bare with me. My Kriesler 11-77/78 goes extremely well,however Ive noticed that as it heats up 3/4 of an Lp or 15-20 mins it starts to get a crackling ksh ksh with some crackle, I think sort of sound. it happens on both radio and T/T but only when it gets warm. So as its warming up say the first 15-20 mins it seems fine but then it sets in. Any ideas of where my issue is? When I turn volume up it does seem to overide it although it is still there and as volume is turned down you can hear it more. I have cleaned the volume pot and the on/off tone pot. any ideas? Even if I can get an idea of where to start tracking this would be good.


 
 Return to top of page · Post #: 2 · Written at 7:18:05 PM on 9 April 2020.
Vintage Pete's avatar
 Location: Albury, NSW
 Member since 1 May 2016
 Member #: 1919
 Postcount: 1993

Hello, I have a 3,, 11 77 .
I restored one awhile back .
Great units ,but it's paper caps because it's 1960 ,have they been replaced?
The units run hot and had a transformer issue so many were changed. I have parts for these units ,, pete


 
 Return to top of page · Post #: 3 · Written at 7:24:45 PM on 9 April 2020.
Vintage Pete's avatar
 Location: Albury, NSW
 Member since 1 May 2016
 Member #: 1919
 Postcount: 1993

Oh forgot, most of the Kriesler 11 77 speaker transformers are stuffed., They are a Rola 7000 2 ohm , I can tell you where to get new ones re wired to spec if needed


 
 Return to top of page · Post #: 4 · Written at 7:26:27 PM on 9 April 2020.
Ian Robertson's Gravatar
 Location: Belrose, NSW
 Member since 31 December 2015
 Member #: 1844
 Postcount: 1910

In both channels or just one?

Most likely cause, C16 and C17, these are probably those brown bakelite mica caps to ground from pins 1 and 6 of the 12AX7.
Replace with 100pF 600v disc ceramics.

Could also be a noisy resistor, R17 and R19 (270k) being the most likely culprits.

I did assume it would have been recapped by now Pete, but if not, C18 and C19 MUST be replaced, at the very least.


 
 Return to top of page · Post #: 5 · Written at 7:29:52 PM on 9 April 2020.
Vintage Pete's avatar
 Location: Albury, NSW
 Member since 1 May 2016
 Member #: 1919
 Postcount: 1993

Yes ian, remember when I did mine and on start up it got a bad cracks so I replaced the mica as you say and it sounded great .


 
 Return to top of page · Post #: 6 · Written at 7:54:37 PM on 9 April 2020.
Padge's Gravatar
 Location: Umina Beach, NSW
 Member since 9 April 2020
 Member #: 2410
 Postcount: 33

Okay without knowing the exact caps or capacitors I have replaced the two large capacitors and 3 resistors that were around these. one of the resistors was cracked. one of the caps was leaking and there was a hum so replaced both and this took hum away. Where can I get a schematics and can we download pics onto here so I can show what ive done? And thanks. If the the speaker transformer is stuffed how do I check this?


 
 Return to top of page · Post #: 7 · Written at 7:55:47 PM on 9 April 2020.
Padge's Gravatar
 Location: Umina Beach, NSW
 Member since 9 April 2020
 Member #: 2410
 Postcount: 33

Oh and Ian its both channels.


 
 Return to top of page · Post #: 8 · Written at 8:03:51 PM on 9 April 2020.
Vintage Pete's avatar
 Location: Albury, NSW
 Member since 1 May 2016
 Member #: 1919
 Postcount: 1993

Kevin chant web site and you can download load it from there for free


 
 Return to top of page · Post #: 9 · Written at 8:06:54 PM on 9 April 2020.
Padge's Gravatar
 Location: Umina Beach, NSW
 Member since 9 April 2020
 Member #: 2410
 Postcount: 33

Hey pete I went on there and couldnt find it mate.


 
 Return to top of page · Post #: 10 · Written at 8:07:34 PM on 9 April 2020.
Padge's Gravatar
 Location: Umina Beach, NSW
 Member since 9 April 2020
 Member #: 2410
 Postcount: 33

Do you know which pdf it is?


 
 Return to top of page · Post #: 11 · Written at 8:09:33 PM on 9 April 2020.
Vintage Pete's avatar
 Location: Albury, NSW
 Member since 1 May 2016
 Member #: 1919
 Postcount: 1993

It should be there ,it has always been there, Ian may email you one ,I'm on a phone ,no computer at the moment . So although I have it I can't access it for you .
Pete


 
 Return to top of page · Post #: 12 · Written at 8:10:33 PM on 9 April 2020.
Padge's Gravatar
 Location: Umina Beach, NSW
 Member since 9 April 2020
 Member #: 2410
 Postcount: 33

Nice work just got it.cheers pete and ian.


 
 Return to top of page · Post #: 13 · Written at 8:12:50 PM on 9 April 2020.
Vintage Pete's avatar
 Location: Albury, NSW
 Member since 1 May 2016
 Member #: 1919
 Postcount: 1993

It's there I just checked.
Pdf 11 77


 
 Return to top of page · Post #: 14 · Written at 8:24:58 PM on 9 April 2020.
GTC's avatar
 GTC
 Location: Sydney, NSW
 Member since 28 January 2011
 Member #: 823
 Postcount: 6013

 
 Return to top of page · Post #: 15 · Written at 8:32:07 PM on 9 April 2020.
Vintage Pete's avatar
 Location: Albury, NSW
 Member since 1 May 2016
 Member #: 1919
 Postcount: 1993

Kevin's schematic is good ,it has a parts list which I think was great ,they don't alway have that . When I did mine I ordered the caps off just radios and all went good .
Look after your speakers ,they are 2 ohms and impossible to find if you stuff one


 
« Back · 1 · 2 · 3 · 4 · 5 · 6 · Next »
 You need to be a member to post comments on this forum.

Sign In

Username:
Password:
 Keep me logged in.
Do not tick box on a computer with public access.