Welcome to Australia's only Vintage Radio and Television discussion forums. You are not logged in. Please log in below, apply for an account or retrieve your password.
Australian Vintage Radio Forums
  Home  ·  About Us  ·  Discussion Forums  ·  Glossary  ·  Outside Links  ·  Policies  ·  Services Directory  ·  Safety Warnings  ·  Tutorials

Tech Talk

Forum home - Go back to Tech talk

 Kriesler 11-104 stylus
« Back · 1 · Next »
 Return to top of page · Post #: 1 · Written at 11:48:49 AM on 6 August 2020.
Feral's Gravatar
 Location: Newcacastle, NSW
 Member since 14 October 2017
 Member #: 2175
 Postcount: 4

Hey all,
My 11-104 has been going great for ages but suddenly I am not getting any sound from the record.
I turned the sound right up and got some music and fiddled with the stylus but no luck.
Could the stylus be gone?
Or some sort of wiring problem?
Where do you get good stlii from?
Cheers


 
 Return to top of page · Post #: 2 · Written at 6:19:36 PM on 6 August 2020.
GTC's avatar
 GTC
 Location: Sydney, NSW
 Member since 28 January 2011
 Member #: 823
 Postcount: 6012

If gently 'pricking' the stylus generates no sound, then try the next step.

(Carefully) remove the connectors from the cartridge and touch each of the hot leads (typically red & white), with the volume mid way you should hear a loud hum. If that's the case, then the signal is being lost in the cartridge. If not, then there's a problem between the cartridge and the amplifier.

I think the original turntable is Garrard 1025.

Here's one source of stylus: https://www.soundring.com.au/soundring-d442sr-2-dual-stereo-ceramic-stylus/


 
« Back · 1 · Next »
 You need to be a member to post comments on this forum.

Sign In

Username:
Password:
 Keep me logged in.
Do not tick box on a computer with public access.